<!DOCTYPE html>
<!--[if lt IE 7 ]><html class="ie ie6 no-js" lang="en-US"> <![endif]-->
<!--[if IE 7 ]><html class="ie ie7 no-js" lang="en-US"> <![endif]-->
<!--[if IE 8 ]><html class="ie ie8 no-js" lang="en-US"> <![endif]-->
<!--[if (gte IE 9)|!(IE)]><!--><html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
	
	<!-- Basic Page Needs
  ================================================== -->
	<meta charset="utf-8">
    
    <meta http-equiv="X-UA-Compatible" content="IE=Edge"/> 
	<!-- Mobile Specific Metas
  ================================================== -->
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/> 

	<!--[if lt IE 9]>
    <script src="https://haitiantimes.com/wp-content/themes/citynews/js/html5shiv.js" type="text/javascript"></script>
    <![endif]-->

    <title>Haitian Times News Roundup – Mar. 12 &#8211; The Haitian Times</title>
<style type="text/css">			.heateorSssInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateorSssSharing,.heateor_sss_standard_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_horizontal_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_horizontal_sharing .heateorSssSharing:hover,.heateor_sss_standard_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing .heateorSssSharing,.heateor_sss_floating_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_vertical_sharing .heateorSssSharing:hover,.heateor_sss_floating_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sss_floating_follow_icons_container{display:none!important}}</style><!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="n-IwZguhq_ZzzWZ9i0wnDgvnSnFE6hgqO0JUDb7fboA" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//www.geoplugin.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Haitian Times &raquo; Feed" href="https://haitiantimes.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Haitian Times &raquo; Comments Feed" href="https://haitiantimes.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Haitian Times &raquo; Haitian Times News Roundup – Mar. 12 Comments Feed" href="https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/feed/" />
<script type="text/javascript">var $TS_VCSC_Lightbox_Activated = true;var $TS_VCSC_Lightbox_Thumbs = "bottom";var $TS_VCSC_Lightbox_Thumbsize = 50;var $TS_VCSC_Lightbox_Animation = "random";var $TS_VCSC_Lightbox_Captions = "data-title";var $TS_VCSC_Lightbox_Closer = true;var $TS_VCSC_Lightbox_Durations = 5000;var $TS_VCSC_Lightbox_Share = false;var $TS_VCSC_Lightbox_LoadAPIs = true;var $TS_VCSC_Lightbox_Social = "fb,tw,gp,pin";var $TS_VCSC_Lightbox_NoTouch = false;var $TS_VCSC_Lightbox_BGClose = true;var $TS_VCSC_Lightbox_NoHashes = true;var $TS_VCSC_Lightbox_Keyboard = true;var $TS_VCSC_Lightbox_FullScreen = true;var $TS_VCSC_Lightbox_Zoom = true;var $TS_VCSC_Lightbox_FXSpeed = 300;var $TS_VCSC_Lightbox_Scheme = "dark";var $TS_VCSC_Lightbox_Backlight = "#ffffff";var $TS_VCSC_Lightbox_UseColor = false;var $TS_VCSC_Lightbox_Overlay = "#000000";var $TS_VCSC_Lightbox_Background = "";var $TS_VCSC_Lightbox_Repeat = "no-repeat";var $TS_VCSC_Lightbox_Noise = "";var $TS_VCSC_Lightbox_CORS = false;var $TS_VCSC_Lightbox_Tapping = true;var $TS_VCSC_Lightbox_ScrollBlock = "css";var $TS_VCSC_Lightbox_Protection = "none";var $TS_VCSC_Lightbox_HomeURL = "https://haitiantimes.com";var $TS_VCSC_Lightbox_LastScroll = 0;var $TS_VCSC_Lightbox_Showing = false;var $TS_VCSC_Hammer_ReleaseNew = true;var $TS_VCSC_Countdown_DaysLabel = "Days";var $TS_VCSC_Countdown_DayLabel = "Day";var $TS_VCSC_Countdown_HoursLabel = "Hours";var $TS_VCSC_Countdown_HourLabel = "Hour";var $TS_VCSC_Countdown_MinutesLabel = "Minutes";var $TS_VCSC_Countdown_MinuteLabel = "Minute";var $TS_VCSC_Countdown_SecondsLabel = "Seconds";var $TS_VCSC_Countdown_SecondLabel = "Second";var $TS_VCSC_RowEffects_Breakpoint = 600;</script>		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/haitiantimes.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ -->		<script>
			//@formatter:off
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='gtranslate-style-css'  href='https://haitiantimes.com/wp-content/plugins/gtranslate/gtranslate-style24.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://haitiantimes.com/wp-content/plugins/gutenberg/build/block-library/style.css?ver=1565170841' type='text/css' media='all' />
<link rel='stylesheet' id='unslider-css-css'  href='https://haitiantimes.com/wp-content/plugins/advanced-ads-slider/public/assets/css/unslider.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='slider-css-css'  href='https://haitiantimes.com/wp-content/plugins/advanced-ads-slider/public/assets/css/slider.css?ver=1.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://haitiantimes.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='mailerlite_forms.css-css'  href='https://haitiantimes.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/css/mailerlite_forms.css?ver=1.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-show-posts-css'  href='https://haitiantimes.com/wp-content/plugins/wp-show-posts/css/wp-show-posts-min.css?ver=1.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-slick-style-css'  href='https://haitiantimes.com/wp-content/plugins/wp-team-showcase-and-slider/assets/css/slick.css?ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-magnific-popup-style-css'  href='https://haitiantimes.com/wp-content/plugins/wp-team-showcase-and-slider/assets/css/magnific-popup.css?ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='tsas-public-style-css'  href='https://haitiantimes.com/wp-content/plugins/wp-team-showcase-and-slider/assets/css/teamshowcase-style.css?ver=2.1' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://haitiantimes.com/wp-content/themes/citynews-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='skeleton1200-css'  href='https://haitiantimes.com/wp-content/themes/citynews/assets/css/skeleton1200.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-reset-css'  href='https://haitiantimes.com/wp-content/themes/citynews/assets/css/reset.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-main-css'  href='https://haitiantimes.com/wp-content/themes/citynews/assets/css/main.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-javascript-css'  href='https://haitiantimes.com/wp-content/themes/citynews/assets/css/javascript.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-responsive-css'  href='https://haitiantimes.com/wp-content/themes/citynews/assets/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='custom-css'  href='https://haitiantimes.com/wp-content/themes/citynews/custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='https://haitiantimes.com/wp-content/themes/citynews/assets/css/responsive.css' type='text/css' media='all' />
<link rel='stylesheet' id='citynews-default-fonts-css'  href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C600%2C700%2C900%2C400italic%2C600italic%2C700italic%2C900italic%7CPT+Serif%3A400%2C700%2C400italic%2C700italic%7CRoboto+Slab%3A400%2C700%2C300%2C100%7CVoltaire&#038;subset=latin%2Clatin-ext%2Cvietnamese%2Ccyrillic-ext%2Ccyrillic%2Cgreek%2Cgreek-ext' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://haitiantimes.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_sharing_default_svg-css'  href='https://haitiantimes.com/wp-content/plugins/sassy-social-share/admin/css/sassy-social-share-svg.css?ver=3.3.7' type='text/css' media='all' />
<link rel='stylesheet' id='vc-custom-css'  href='https://haitiantimes.com/wp-content/themes/citynews/vc_extends/vc_custom.css' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://haitiantimes.com/wp-content/themes/citynews-child/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bsf-Defaults-css'  href='https://haitiantimes.com/wp-content/uploads/smile_fonts/Defaults/Defaults.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/7.1.1/css/jetpack.css' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/7.1.1/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ai_front = {"wp_ai":"5.3.2+2.5.10","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/ad-inserter/includes/js/ai-jquery.js?ver=5.3.2+2.5.10'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-slider/public/assets/js/unslider.min.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.move.js?ver=1.3.2'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-slider/public/assets/js/jquery.event.swipe.js?ver=1.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/haitiantimes.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.6.2'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.js?ver=1.16.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.6.2'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.6.2'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/modernizr.custom.41385.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jflickrfeed.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.colorbox.js'></script>
<link rel='https://api.w.org/' href='https://haitiantimes.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://haitiantimes.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://haitiantimes.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Haitian-American businessmen convicted of port bribery scheme get new trial' href='https://haitiantimes.com/2020/03/12/haitian-american-businessmen-convicted-of-port-bribery-scheme-get-new-trial/' />
<link rel='next' title='Top Winners, Losers After Wednesday&#8217;s Champions League Round-of-16 Leg-2 Results' href='https://haitiantimes.com/2020/03/12/top-winners-losers-after-wednesdays-champions-league-round-of-16-leg-2-results/' />
<link rel="canonical" href="https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" />
<link rel='shortlink' href='https://haitiantimes.com/?p=29113' />
<link rel="alternate" type="application/json+oembed" href="https://haitiantimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://haitiantimes.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F&#038;format=xml" />
<script type="text/javascript">
  window.MemberfulOptions = {
    site: "https://haitiantimes.memberful.com",
    intercept: [
            "https://haitiantimes.com/?memberful_endpoint=auth",
            "https://haitiantimes.com/?memberful_endpoint=auth",
            "https://haitiantimes.com?memberful_endpoint=auth",
            "https://haitiantimes.com?memberful_endpoint=auth",
          ],
    memberSignedIn: false  };

  (function() {
    var s = document.createElement('script');
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); }

    if(s.addEventListener) {
      s.addEventListener("load", setup, false);
    } else {
      s.attachEvent("onload", setup);
    }

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();
</script>

<!-- StarBox - the Author Box for Humans 1.3.1, visit: http://wordpress.org/plugins/starbox/ -->
<meta property="article:author" content="https://www.facebook.com/TheHaitianTimes?ref=settings" />
<!-- /StarBox - the Author Box for Humans -->

<link rel='stylesheet' id='frontend.css-css'  href='https://haitiantimes.com/wp-content/plugins/starbox-pro//themes/business/css/frontend.css?ver=1.3.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/starbox-pro//themes/business/js/frontend.js?ver=1.3.1'></script>
<link rel='stylesheet' id='hidedefault.css-css'  href='https://haitiantimes.com/wp-content/plugins/starbox-pro//themes/admin/css/hidedefault.css?ver=1.3.1' type='text/css' media='all' />
<!-- <meta name="NextGEN" version="3.2.23" /> -->
<script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="haiti-layer-custom-css"></style><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">
/*Custom CSS*/
.wp-caption {
max-width: 100%;
}
</style>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-53175951-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-53175951-1');
</script>


		<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://haitiantimes.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://haitiantimes.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]-->      <meta name="onesignal" content="wordpress-plugin"/>
        <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://haitiantimes.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'aeac1f71-d522-4976-9289-840de7ab4e19';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://haitiantimes.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'medium';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<meta name="description" content="Haiti Weapons seized at the port of Cap-Haitien Brigadiers of the General Customs Administration (AGD) seized three firearms at the port of Cap-Haitien Wednesday morning. During a check of containers at Cap-Haitien customs as part of the fight against fraud and smuggling, a brigade discovered three firearms including an M4 rifle, a 9mm caliber pistol&hellip;" />

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Haitian Times News Roundup – Mar. 12" />
<meta property="og:url" content="https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" />
<meta property="og:description" content="Haiti Weapons seized at the port of Cap-Haitien Brigadiers of the General Customs Administration (AGD) seized three firearms at the port of Cap-Haitien Wednesday morning. During a check of containe…" />
<meta property="article:published_time" content="2020-03-12T12:41:02+00:00" />
<meta property="article:modified_time" content="2020-03-12T12:41:05+00:00" />
<meta property="og:site_name" content="The Haitian Times" />
<meta property="og:image" content="https://haitiantimes.com/wp-content/uploads/2020/03/SmartSelect_20200311-131613_WhatsApp.jpg" />
<meta property="og:image:width" content="1409" />
<meta property="og:image:height" content="818" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@HaitianTimes_" />
<meta name="twitter:text:title" content="Haitian Times News Roundup – Mar. 12" />
<meta name="twitter:image" content="https://haitiantimes.com/wp-content/uploads/2020/03/SmartSelect_20200311-131613_WhatsApp.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
		<script data-cfasync="false" type="text/javascript">
			var __ATA_PP = { pt: 1, ht: 2, tn: 'citynews-child', amp: false, siteid: 76793838, consent: 0 };
			var __ATA = __ATA || {};
			__ATA.cmd = __ATA.cmd || [];
			__ATA.criteo = __ATA.criteo || {};
			__ATA.criteo.cmd = __ATA.criteo.cmd || [];
		</script>		<link rel='dns-prefetch' href='//s.pubmine.com' />
		<link rel='dns-prefetch' href='//x.bidswitch.net' />
		<link rel='dns-prefetch' href='//static.criteo.net' />
		<link rel='dns-prefetch' href='//ib.adnxs.com' />
		<link rel='dns-prefetch' href='//aax.amazon-adsystem.com' />
		<link rel='dns-prefetch' href='//bidder.criteo.com' />
		<link rel='dns-prefetch' href='//cas.criteo.com' />
		<link rel='dns-prefetch' href='//gum.criteo.com' />
		<link rel='dns-prefetch' href='//ads.pubmatic.com' />
		<link rel='dns-prefetch' href='//gads.pubmatic.com' />
		<link rel='dns-prefetch' href='//tpc.googlesyndication.com' />
		<link rel='dns-prefetch' href='//ad.doubleclick.net' />
		<link rel='dns-prefetch' href='//googleads.g.doubleclick.net' />
		<link rel='dns-prefetch' href='//www.googletagservices.com' />
		<script data-cfasync="false" async type="text/javascript" src="//s.pubmine.com/head.js"></script><link rel="icon" href="https://haitiantimes.com/wp-content/uploads/2017/02/icon-logo-150x150.png" sizes="32x32" />
<link rel="icon" href="https://haitiantimes.com/wp-content/uploads/2017/02/icon-logo.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://haitiantimes.com/wp-content/uploads/2017/02/icon-logo-180x180.png" />
<meta name="msapplication-TileImage" content="https://haitiantimes.com/wp-content/uploads/2017/02/icon-logo.png" />
		<div class="wpcnt wpcnt-header">
			<div class="wpa">
				<span class="wpa-about">Advertisements</span>
				<div class="u top">
							<div style="padding-bottom:15px;width:728px;height:90px;">
			<div id="atatags-1">
				<script data-cfasync="false" type="text/javascript">
				__ATA.cmd.push(function() {
					__ATA.initSlot('atatags-1',  {
						collapseEmpty: 'before',
						sectionId: '767938382',
						location: 'top',
						width: 728,
						height: 90
					});
				});
				</script>
			</div>
		</div>
				</div>
			</div>
		</div><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><link rel='stylesheet' id='ccc-currency-converter-calculator-css'  href='https://haitiantimes.com/wp-content/plugins/currency-converter-calculator/assets/frontend.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='alaya_shortcodes-css'  href='https://haitiantimes.com/wp-content/themes/citynews/inc/shortcodes/css/shortcodes.css' type='text/css' media='all' />
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-29113 single-format-standard wpb-js-composer js-comp-ver-4.12.1 vc_responsive">
 
<!-- Pushy Menu -->
<nav class="pushy pushy-left">
    <ul>
        <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28022"><a href="https://haitiantimes.com/dashed-dreamshaiti-since-the-2010-quake/">Dashed Dreams: Haiti Since the 2010 Quake</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18227"><a href="https://haitiantimes.com/category/tps/">TPS</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19599"><a href="https://haitiantimes.com/category/haitians-in-america/">Haitians In America</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15215"><a href="https://haitiantimes.com/category/haiti/">Haiti</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14862"><a href="https://haitiantimes.com/category/new-york/">New York</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14861"><a href="https://haitiantimes.com/category/florida/">Florida</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15007"><a href="https://haitiantimes.com/category/boston/">Boston</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17286"><a href="https://haitiantimes.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70"><a href="https://haitiantimes.com/category/arts-culture/">Arts &#038; Culture</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69"><a href="https://haitiantimes.com/category/health-science/">Health &#038; Science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-15487"><a href="https://haitiantimes.com/category/special-reports/">Special Reports</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-22039"><a href="#">More</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22832"><a href="https://haitiantimes.com/category/immigrant-voices/">Immigrant Voices</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22831"><a href="https://haitiantimes.com/category/montreal/">Montreal</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22040"><a href="https://haitiantimes.com/category/opinion/">Opinion</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22041"><a href="https://haitiantimes.com/currency-converter/">CURRENCY CONVERTER</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22042"><a href="https://haitiantimes.com/category/warped-lens/">Warped Lens</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22043"><a href="https://haitiantimes.com/category/tech/">TECHNOLOGY</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22044"><a href="https://haitiantimes.com/category/style/">Beauty &#038; Style</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22045"><a href="https://haitiantimes.com/category/profiles/">Profiles</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22046"><a href="https://haitiantimes.com/category/entertainment/">Entertainment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22047"><a href="https://haitiantimes.com/category/sports/">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22048"><a href="https://haitiantimes.com/category/columns/">Columns</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22049"><a href="https://haitiantimes.com/category/features/">Features</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22050"><a href="https://haitiantimes.com/category/photo-gallery/">Photo Gallery</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-22051"><a href="https://haitiantimes.com/category/video/">Video</a></li>
</ul>
</li>
<li style="position:relative;" class="menu-item menu-item-gtranslate"><div style="position:absolute;" id="gtranslate_wrapper"><!-- GTranslate: https://gtranslate.io/ -->
<style type="text/css">
.switcher {font-family:Arial;font-size:10pt;text-align:left;cursor:pointer;overflow:hidden;width:163px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:10pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#FFFFFF url(//haitiantimes.com/wp-content/plugins/gtranslate/switcher.png) repeat-x;position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #CCCCCC;background:url(//haitiantimes.com/wp-content/plugins/gtranslate/arrow_down.png) 146px center no-repeat;color:#666666;padding:3px 5px;width:151px;}
.switcher .selected a.open {background-image:url(//haitiantimes.com/wp-content/plugins/gtranslate/arrow_up.png)}
.switcher .selected a:hover {background:#F0F0F0 url(//haitiantimes.com/wp-content/plugins/gtranslate/arrow_down.png) 146px center no-repeat;}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #CCCCCC;border-right:1px solid #CCCCCC;border-bottom:1px solid #CCCCCC;background-color:#EEEEEE;display:none;width:161px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#FFC;}
.switcher .option a.selected {background:#FFC;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#F5F5F5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/en-us.png" height="16" width="16" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/en-us.png" height="16" width="16" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|fr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="French" class="nturl"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/fr.png" height="16" width="16" alt="fr" /> French</a><a href="#" onclick="doGTranslate('en|ht');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Haitian Creole" class="nturl"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/ht.png" height="16" width="16" alt="ht" /> Haitian Creole</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/es.png" height="16" width="16" alt="es" /> Spanish</a></div>
</div>
<script type="text/javascript">
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style type="text/css">
#goog-gt-tt {display:none !important;}
.goog-te-banner-frame {display:none !important;}
.goog-te-menu-value:hover {text-decoration:none !important;}
.goog-text-highlight {background-color:transparent !important;box-shadow:none !important;}
body {top:0 !important;}
#google_translate_element2 {display:none!important;}
</style>

<div id="google_translate_element2"></div>
<script type="text/javascript">
function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script>


<script type="text/javascript">
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(/goog-te-combo/.test(sel[i].className)){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
</div></li>    </ul>
</nav>

<!-- Site Overlay -->
<div class="site-overlay"></div> 
 <div id="body-container">
      <!--Top Bar-->
      <div id="topbar">
           <!--Social Icons-->
	       		   <!--Menu button-->
           <div class="menu_button hide"><a href="javascript:void(0)"><i class="fa fa-bars"></i></a></div>
           
	       <!--Tools-->
		         </div> 
           
	        <header id="top" class="aaaaa">
      
	     <!--<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>-->

<script data-ad-client="ca-pub-1581876459173802" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		  
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/559778808/Article_Rectangle1_300x250', [300, 250], 'div-gpt-ad-1478596239649-0').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Article_Rectangle_300x250', [300, 250], 'div-gpt-ad-1478596239649-1').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Rectangle1_300x250', [300, 250], 'div-gpt-ad-1478596239649-2').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Rectangle2_300x250', [300, 250], 'div-gpt-ad-1478596239649-3').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Rectangle3_300x250', [300, 250], 'div-gpt-ad-1478596239649-4').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Leaderboard_Article_728x90', [728, 90], 'div-gpt-ad-1478596239649-5').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Leaderboard_ABF_728x90', [728, 90], 'div-gpt-ad-1478596239649-6').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Leaderboard_BTF_728x90', [728, 90], 'div-gpt-ad-1478596239649-7').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Leaderboard_Header_728x90', [728, 90], 'div-gpt-ad-1478596239649-8').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Left_Rectangle_Header', [300, 120], 'div-gpt-ad-1478596239649-9').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Mobile_320x50', [320, 50], 'div-gpt-ad-1478596239649-10').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Right_Header_Rectangle', [300, 120], 'div-gpt-ad-1478596239649-11').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Skyscraper_Article_300x600', [300, 600], 'div-gpt-ad-1478596239649-12').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Skyscraper_Homepage_300x600', [300, 600], 'div-gpt-ad-1478596239649-13').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Superleaderboard', [970, 250], 'div-gpt-ad-1478596239649-14').addService(googletag.pubads());
   googletag.defineSlot('/559778808/Homepage_Rectangle_Footer', [300, 250], 'div-gpt-ad-1479334217814-0').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Leaderboard1_728x90', [728, 90], 'div-gpt-ad-1479334217814-1').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Leaderboard2_728x90', [728, 90], 'div-gpt-ad-1479334217814-2').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Leaderboard3_728x90', [728, 90], 'div-gpt-ad-1479334217814-3').addService(googletag.pubads());
    googletag.defineSlot('/559778808/Homepage_Leaderboard4_728x90', [728, 90], 'div-gpt-ad-1479334217814-4').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.pubads().collapseEmptyDivs();
    googletag.enableServices();
  });
</script>         
        
	      <!--LOGO-->
	      <div class="logo">

	        <a href="https://haitiantimes.com/" title="The Haitian Times">
	        	          <span><img src="https://haitiantimes.com/wp-content/uploads/2019/10/Web-Logo_20th-1.png" /></span>
	        	        </a>
	        <div class="local_info">
	          	          	          <!--<span id="weather"></span>-->
		   </div>
			<div class="signup-top-buttons"><a href="https://haitiantimes.com/support/">subscribe now</a> <a href="https://haitiantimes.com/?memberful_endpoint=auth">sign in</a></div>
		   		   		   <div style="clear: both;"></div>


	      </div>
     
        
        
	      <!--Primary Menu-->
	      <nav id="primary_menu">
		     <ul class="sf-menu">
			   <li id="menu-item-28022" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://haitiantimes.com/dashed-dreamshaiti-since-the-2010-quake/">Dashed Dreams: Haiti Since the 2010 Quake</a></li>
<li id="menu-item-18227" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/tps/">TPS</a></li>
<li id="menu-item-19599" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/haitians-in-america/">Haitians In America</a></li>
<li id="menu-item-15215" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/haiti/">Haiti</a></li>
<li id="menu-item-14862" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/new-york/">New York</a></li>
<li id="menu-item-14861" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/florida/">Florida</a></li>
<li id="menu-item-15007" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/boston/">Boston</a></li>
<li id="menu-item-17286" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/news/">News</a></li>
<li id="menu-item-70" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/arts-culture/">Arts &#038; Culture</a></li>
<li id="menu-item-69" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/health-science/">Health &#038; Science</a></li>
<li id="menu-item-15487" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/special-reports/">Special Reports</a></li>
<li id="menu-item-22039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="#">More</a>
<ul class="sub-menu">
	<li id="menu-item-22832" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/immigrant-voices/">Immigrant Voices</a></li>
	<li id="menu-item-22831" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/montreal/">Montreal</a></li>
	<li id="menu-item-22040" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/opinion/">Opinion</a></li>
	<li id="menu-item-22041" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://haitiantimes.com/currency-converter/">CURRENCY CONVERTER</a></li>
	<li id="menu-item-22042" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/warped-lens/">Warped Lens</a></li>
	<li id="menu-item-22043" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/tech/">TECHNOLOGY</a></li>
	<li id="menu-item-22044" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/style/">Beauty &#038; Style</a></li>
	<li id="menu-item-22045" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/profiles/">Profiles</a></li>
	<li id="menu-item-22046" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/entertainment/">Entertainment</a></li>
	<li id="menu-item-22047" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/sports/">Sports</a></li>
	<li id="menu-item-22048" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/columns/">Columns</a></li>
	<li id="menu-item-22049" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/features/">Features</a></li>
	<li id="menu-item-22050" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/photo-gallery/">Photo Gallery</a></li>
	<li id="menu-item-22051" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://haitiantimes.com/category/video/">Video</a></li>
</ul>
</li>
<li style="position:relative;" class="menu-item menu-item-gtranslate"><div style="position:absolute;" id="gtranslate_wrapper"><!-- GTranslate: https://gtranslate.io/ -->
<style type="text/css">
.switcher {font-family:Arial;font-size:10pt;text-align:left;cursor:pointer;overflow:hidden;width:163px;line-height:17px;}
.switcher a {text-decoration:none;display:block;font-size:10pt;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;}
.switcher a img {vertical-align:middle;display:inline;border:0;padding:0;margin:0;opacity:0.8;}
.switcher a:hover img {opacity:1;}
.switcher .selected {background:#FFFFFF url(//haitiantimes.com/wp-content/plugins/gtranslate/switcher.png) repeat-x;position:relative;z-index:9999;}
.switcher .selected a {border:1px solid #CCCCCC;background:url(//haitiantimes.com/wp-content/plugins/gtranslate/arrow_down.png) 146px center no-repeat;color:#666666;padding:3px 5px;width:151px;}
.switcher .selected a.open {background-image:url(//haitiantimes.com/wp-content/plugins/gtranslate/arrow_up.png)}
.switcher .selected a:hover {background:#F0F0F0 url(//haitiantimes.com/wp-content/plugins/gtranslate/arrow_down.png) 146px center no-repeat;}
.switcher .option {position:relative;z-index:9998;border-left:1px solid #CCCCCC;border-right:1px solid #CCCCCC;border-bottom:1px solid #CCCCCC;background-color:#EEEEEE;display:none;width:161px;max-height:198px;-webkit-box-sizing:content-box;-moz-box-sizing:content-box;box-sizing:content-box;overflow-y:auto;overflow-x:hidden;}
.switcher .option a {color:#000;padding:3px 5px;}
.switcher .option a:hover {background:#FFC;}
.switcher .option a.selected {background:#FFC;}
#selected_lang_name {float: none;}
.l_name {float: none !important;margin: 0;}
.switcher .option::-webkit-scrollbar-track{-webkit-box-shadow:inset 0 0 3px rgba(0,0,0,0.3);border-radius:5px;background-color:#F5F5F5;}
.switcher .option::-webkit-scrollbar {width:5px;}
.switcher .option::-webkit-scrollbar-thumb {border-radius:5px;-webkit-box-shadow: inset 0 0 3px rgba(0,0,0,.3);background-color:#888;}
</style>
<div class="switcher notranslate">
<div class="selected">
<a href="#" onclick="return false;"><img src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/en-us.png" height="16" width="16" alt="en" /> English</a>
</div>
<div class="option">
<a href="#" onclick="doGTranslate('en|en');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="English" class="nturl selected"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/en-us.png" height="16" width="16" alt="en" /> English</a><a href="#" onclick="doGTranslate('en|fr');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="French" class="nturl"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/fr.png" height="16" width="16" alt="fr" /> French</a><a href="#" onclick="doGTranslate('en|ht');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Haitian Creole" class="nturl"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/ht.png" height="16" width="16" alt="ht" /> Haitian Creole</a><a href="#" onclick="doGTranslate('en|es');jQuery('div.switcher div.selected a').html(jQuery(this).html());return false;" title="Spanish" class="nturl"><img data-gt-lazy-src="//haitiantimes.com/wp-content/plugins/gtranslate/flags/16/es.png" height="16" width="16" alt="es" /> Spanish</a></div>
</div>
<script type="text/javascript">
jQuery('.switcher .selected').click(function() {jQuery('.switcher .option a img').each(function() {if(!jQuery(this)[0].hasAttribute('src'))jQuery(this).attr('src', jQuery(this).attr('data-gt-lazy-src'))});if(!(jQuery('.switcher .option').is(':visible'))) {jQuery('.switcher .option').stop(true,true).delay(100).slideDown(500);jQuery('.switcher .selected a').toggleClass('open')}});
jQuery('.switcher .option').bind('mousewheel', function(e) {var options = jQuery('.switcher .option');if(options.is(':visible'))options.scrollTop(options.scrollTop() - e.originalEvent.wheelDelta);return false;});
jQuery('body').not('.switcher').click(function(e) {if(jQuery('.switcher .option').is(':visible') && e.target != jQuery('.switcher .option').get(0)) {jQuery('.switcher .option').stop(true,true).delay(100).slideUp(500);jQuery('.switcher .selected a').toggleClass('open')}});
</script>
<style type="text/css">
#goog-gt-tt {display:none !important;}
.goog-te-banner-frame {display:none !important;}
.goog-te-menu-value:hover {text-decoration:none !important;}
.goog-text-highlight {background-color:transparent !important;box-shadow:none !important;}
body {top:0 !important;}
#google_translate_element2 {display:none!important;}
</style>

<div id="google_translate_element2"></div>
<script type="text/javascript">
function googleTranslateElementInit2() {new google.translate.TranslateElement({pageLanguage: 'en',autoDisplay: false}, 'google_translate_element2');}
</script><script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit2"></script>


<script type="text/javascript">
function GTranslateGetCurrentLang() {var keyValue = document['cookie'].match('(^|;) ?googtrans=([^;]*)(;|$)');return keyValue ? keyValue[2].split('/')[2] : null;}
function GTranslateFireEvent(element,event){try{if(document.createEventObject){var evt=document.createEventObject();element.fireEvent('on'+event,evt)}else{var evt=document.createEvent('HTMLEvents');evt.initEvent(event,true,true);element.dispatchEvent(evt)}}catch(e){}}
function doGTranslate(lang_pair){if(lang_pair.value)lang_pair=lang_pair.value;if(lang_pair=='')return;var lang=lang_pair.split('|')[1];if(GTranslateGetCurrentLang() == null && lang == lang_pair.split('|')[0])return;var teCombo;var sel=document.getElementsByTagName('select');for(var i=0;i<sel.length;i++)if(/goog-te-combo/.test(sel[i].className)){teCombo=sel[i];break;}if(document.getElementById('google_translate_element2')==null||document.getElementById('google_translate_element2').innerHTML.length==0||teCombo.length==0||teCombo.innerHTML.length==0){setTimeout(function(){doGTranslate(lang_pair)},500)}else{teCombo.value=lang;GTranslateFireEvent(teCombo,'change');GTranslateFireEvent(teCombo,'change')}}
if(GTranslateGetCurrentLang() != null)jQuery(document).ready(function() {var lang_html = jQuery('div.switcher div.option').find('img[alt="'+GTranslateGetCurrentLang()+'"]').parent().html();if(typeof lang_html != 'undefined')jQuery('div.switcher div.selected a').html(lang_html.replace('data-gt-lazy-', ''));});
</script>
</div></li>			</ul>
			
            <div id="tools">
			 <!--Social Icons-->
	       <div class="social_icons">
		       <div class="social-icons clearfix">
<a href="https://www.facebook.com/TheHaitianTimes/?ref=aymt_homepage_panel" title="Facebook" class="facebook" target="_blank"><i class="fa fa-facebook"></i></a> 
 <a href="https://twitter.com/HaitianTimes_" title="Twitter" class="twitter" target="_blank"><i class="fa fa-twitter"></i></a> 
<a href="https://www.instagram.com/haitiantimes/" title="instagram" class="instagram" target="_blank"><i class="fa fa-instagram"></i></a> 
</div>
		   </div>
						   <a href="javascript:void(0);" class="search_btn"><i class="fa fa-search"></i></a>
			 		   </div> 
            
	      </nav>

	      <div class="widget widget_full"><div id="haiti-slider-380" class="custom-slider haiti-slider-414254662 haiti-slider"><ul><li><a data-bid="1" href="https://haitiantimes.com/linkout/26451"><img width="728" height="90" src='https://haitiantimes.com/wp-content/uploads/2019/06/MET2798-Colors-Campaign-Digital-Ads-728x90-ENG.gif' alt=''  /></a></li><li><a data-bid="1" href="https://haitiantimes.com/linkout/27153"><img width="1280" height="165" src='https://haitiantimes.com/wp-content/uploads/2019/09/belmachann1wht.jpeg' alt=''  /></a></li><li><a data-bid="1" href="https://haitiantimes.com/linkout/26481"><img width="2000" height="250" src='https://haitiantimes.com/wp-content/uploads/2019/06/HT_leaderboard-720x90-carenyc-june-2019-1.png' alt=''  /></a></li><li><a data-bid="1" href="https://haitiantimes.com/linkout/25353"><img width="728" height="90" src='https://haitiantimes.com/wp-content/uploads/2019/04/join-us-on-whatsapp-web-leaderboard.png' alt=''  /></a></li></ul></div><script>jQuery(function() {var $haitislider414254662 = jQuery( ".haiti-slider-414254662" );$haitislider414254662.on( "unslider.ready", function() { jQuery( "div.custom-slider ul li" ).css( "display", "block" ); });$haitislider414254662.unslider({ delay:10000, autoplay:true, nav:false, arrows:false });$haitislider414254662.on("mouseover", function(){$haitislider414254662.unslider("stop");}).on("mouseout", function() {$haitislider414254662.unslider("start");});});</script></div>      </header>
      
      
      
      
      <!--1200px Grid-->
      <div id="cn_content" class="container row">
          
          <div id="breadcrumbs">
	         <div class="navi"><i class="fa fa-home"></i><a href="https://haitiantimes.com/">Home</a> <span class="sep">&raquo;</span> <a href="https://haitiantimes.com/category/haitian-times-morning-news-roundup/">Haitian Times Morning News Roundup</a> <span class="sep">&raquo;</span> <span class="current">Haitian Times News Roundup – Mar. 12</span></div> 
	         	         <div class="share">
		           <a href="https://www.facebook.com/sharer/sharer.php?u=https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" target="_blank" class="facebook"><i class="fa fa-facebook"></i></a>
		        <a href="https://twitter.com/share?text=Haitian+Times+News+Roundup+%E2%80%93+Mar.+12&amp;url=https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" target="_blank" class="twitter"><i class="fa fa-twitter"></i></a>
		        <a href="https://plus.google.com/share?url=https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" target="_blank" class="gplus"><i class="fa fa-google-plus"></i></a>
		        <a href="https://pinterest.com/pin/create/button/?media=https://haitiantimes.com/wp-content/uploads/2020/03/SmartSelect_20200311-131613_WhatsApp.jpg&amp;description=Haitian+Times+News+Roundup+%E2%80%93+Mar.+12&amp;url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F" target="_blank" class="pinterest"><i class="fa fa-pinterest"></i></a>
		        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;title=Haitian+Times+News+Roundup+%E2%80%93+Mar.+12&amp;source=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F&amp;url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F" target="_blank" class="linkedin"><i class="fa fa-linkedin"></i></a>
	         </div>
	                   </div>
          
	      <!--Main Content-->
	      <div id="main" class="twelve columns">
	        <div class="standard_blog">          	                  
	                  
                     
		<!---Posts-->
				<article class="post-29113 post type-post status-publish format-standard has-post-thumbnail hentry category-haitian-times-morning-news-roundup">
				
		<div class="entry-body">
				  <span class="category"><a href="https://haitiantimes.com/category/haitian-times-morning-news-roundup/" rel="category tag">Haitian Times Morning News Roundup</a></span>
		  		  <h4 class="entry-title">Haitian Times News Roundup – Mar. 12</h4>
		  		  <span class="title-divider"></span>
				  
		  <div class="entry-content">
		    <div class='heateorSssClear'></div><div style="float: right" class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/'><div class='heateor_sss_sharing_title' style="font-weight:bold" ></div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?text=Haitian%20Times%20News%20Roundup%20%E2%80%93%20Mar.%2012&url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Pinterest" Title="Pinterest" class="heateorSssSharing heateorSssPinterestBackground" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssPinterestSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Linkedin" Title="Linkedin" class="heateorSssSharing heateorSssLinkedinBackground" onclick='heateorSssPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F&title=Haitian%20Times%20News%20Roundup%20%E2%80%93%20Mar.%2012")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssLinkedinSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Whatsapp" Title="Whatsapp" class="heateorSssSharing heateorSssWhatsappBackground"><a  href="https://web.whatsapp.com/send?text=Haitian%20Times%20News%20Roundup%20%E2%80%93%20Mar.%2012 https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F" rel="nofollow noopener" target="_blank"><ss style="display:block" class="heateorSssSharingSvg heateorSssWhatsappSvg"></ss></a></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>
<p><strong><u>Haiti</u></strong></p>



<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Haitian times leftside bar sanjay -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1581876459173802"
     data-ad-slot="5692064866"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong>Weapons seized at the port of Cap-Haitien</strong></p>



<p>Brigadiers of the General Customs Administration (AGD) seized three firearms at the port of Cap-Haitien Wednesday morning.</p>



<p>During a check of containers at Cap-Haitien customs as part of the fight against fraud and smuggling, a brigade discovered three firearms including an M4 rifle, a 9mm caliber pistol and another of caliber 22. The brigade also found 3,100 cartridges, including 1,100 for the M4 assault rifle in the container.</p>



<p>The weapons and ammunition were hidden in new speakers and had not yet been assembled. A justice of the peace went there to make the legal finding, prosecution will be brought against the culprits, said a customs official. No arrests were made.  <a href="https://www.juno7.ht/port-du-cap-haitien-nouvelle-saisie-darmes/">Continue reading</a></p>



<p><strong>ANAMAH calls for strike against insecurity</strong></p>



<p>The National Association of Haitian Magistrates calls on magistrates to observe three days of work stoppage from March 11 to Friday March 13 in protest against the insecurity in the country.</p>



<p>In reference to the attack on the judge at the Court of Appeal Durin Duret Junior and adviser to the CSPJ on March 9, the National Association of Haitian Magistrates (ANAMAH) considers that the red line has been crossed. It requires the serenity necessary for the proper functioning of the Judicial Power. Otherwise, &#8220;the Courts and Tribunals will be forced to cease most of their activities,&#8221; said the note from ANAMAH.</p>



<p>In the meantime, as a warning, the National Association of Haitian Magistrates (ANAMAH) invites magistrates who wish to observe three days of work stoppage from this Wednesday March 11 until Friday March 13 in solidarity with former President Durin Duret Junior, other victim magistrates and with the members of the judicial personnel victims in general to signify its refusal vis-a-vis the tyranny of this climate of generalized insecurity.  <a href="https://www.juno7.ht/lanamah-appelle-a-la-greve-contre-linsecurite/">Continue reading</a></p>



<p><strong>Need for institutional arrangements in response to the imminent risk of the introduction of the Covid-19 pandemic in Haiti</strong></p>



<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Haitian times leftside bar sanjay -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1581876459173802"
     data-ad-slot="5692064866"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Through the Ministries of the Interior and local authorities (Mict), education and vocational training (Menfp), the state authorities call for other authorities to take steps to deal with the imminent risk of the introduction of the Covid-19 pandemic (novel coronavirus) in Haiti. </p>



<p>&#8220;Airlines operating on national territory must take the necessary measures to prohibit the boarding of any passenger from the red zones,&#8221; said a note from the Mict, dated March 9th.</p>



<p>The red areas concerned are &#8220;areas at high risk of Covid-19 contamination, having not spent 14 days outside of a risk-free area (area without local transmission of Covid-19),&#8221; according to the Ministry of interior and local authorities.  <a href="https://www.alterpresse.org/spip.php?article25350#.XmmnpJNKhn4">Continue reading</a></p>



<p><strong>Financial support: Prime Minister Jouthe is racing, and the IMF is waiting for &#8220;the conditions to allow it”</strong></p>



<p>Prime Minister Joseph Jouthe told Le Nouvelliste last Friday that the International Monetary Fund (IMF) welcomes &#8220;the establishment of the government.&#8221; He was optimistic about the resumption of funding stopped for almost a year after the resignation of the government of Jean Henry Céant and the absence of a budget regularly voted by the Parliament.  </p>



<p>“The IMF had asked for a government. The IMF welcomes the establishment of the government. The other donors are waiting for the IMF to open the floodgates to let go of the purse strings, &#8220;he said, stressing that the fund strongly encourages the executive to ”pass a budget by decree.”</p>



<p>The IMF also encourages to draw up decrees with &#8220;the other economic bills which remained blocked in the Parliament since the last two legislatures of which the bill on the cadastre among others&#8221;. &#8220;About 11 bills that remained stuck in Parliament, including the Chamber of Deputies,&#8221; said Jouthe. &#8220;The IMF also wants to have elections this year.” <a href="https://lenouvelliste.com/article/213240/support-financier-le-premier-ministre-jouthe-semballe-le-fmi-attend-que-les-conditions-le-permettent">Continue reading</a></p>



<p><strong>Haitian-American businessmen convicted of port bribery scheme get new trial</strong></p>



<p>Two Haitian-American businessmen convicted of conspiring to pay millions of dollars in bribes to Haitian government officials, including the aide to a prime minister, for a northwest Haiti port will be getting a new trial.</p>



<p>Dr. Joseph Baptiste, a Maryland dentist and retired Haitian-American U.S. Army colonel, and Roger Richard Boncy, a former Haitian ambassador-at-large, were found guilty in June by a Boston federal jury of an $84 million Haiti port bribery scheme. Jurors convicted both men of conspiring to violate the Foreign Corrupt Practices Act and the Travel Act. Baptiste was also convicted of conspiracy to commit money laundering and an additional Travel Act violation, while Boncy was cleared of the two counts. <a href="https://www.miamiherald.com/news/nation-world/world/americas/haiti/article241095571.html">Continue reading</a> </p>



<p><strong><u>Florida</u></strong></p>



<p><strong>Fighting for the Soul of Little Haiti in Miami</strong></p>



<div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Haitian times leftside bar sanjay -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-1581876459173802"
     data-ad-slot="5692064866"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>In the 1970s and 1980s, thousands of Haitian refugees fleeing the brutal Duvalier dictatorship landed on Florida’s southern shores. Many settled in Lemon City, an economically disadvantaged Miami neighborhood north of downtown’s glitz and grit and across Biscayne Bay from South Beach’s famed white sand and aquamarine sea.</p>



<p>The neighborhood came to be known as Little Haiti. Though Miamians made it plain that Haitians weren’t welcome elsewhere in the city, here within the boundaries of Lemon City, the Haitians had a community. <a href="https://caseygrants.org/evn/fighting-for-the-soul-of-little-haiti-in-miami/">Continue reading</a> </p>



<p><strong><u>Editorial</u></strong></p>



<p><strong>Why the Haitian Diaspora Has an Important Role to Play in US Elections</strong></p>



<p>The Florida Democratic primary is only a week away, and as candidates turn their attention to the Sunshine state the Haitian diaspora has a unique opportunity to put Haitian issues on agenda. Especially Cubans, but also, more recently Venezuelans have been extremely effective in organizing themselves in the diaspora to push for their desired US policy.  When Florida politics come up, that’s where the focus usually lands. </p>



<p>But often overlooked in this conversation are the more than 300,000 residents of Florida who were born in Haiti, and the hundreds of thousands more who report having Haitian ancestry. In raw numbers, the Haitian diaspora in Florida is more than double the size of the Venezuelan diaspora. And it is not limited solely to Florida; there are significant population centers of Haitian diaspora in both New York and Massachusetts. <a href="https://haitiantimes.com/2020/03/12/why-the-haitian-diaspora-has-an-important-role-to-play-in-us-elections/">Continue reading</a></p>

                         <div class="abh_box abh_box_down abh_box_business"><ul class="abh_tabs"> <li class="abh_about abh_active"><a href="#abh_about">About</a></li> <li class="abh_posts"><a href="#abh_posts">Latest Posts</a></li></ul><div class="abh_tab_content"><section class="vcard abh_about_tab abh_tab" style="display:block"><div class="abh_image"><a href="https://haitiantimes.com/author/admin/" class="url" title="Haitian Times"><img alt='Haitian Times' src='https://haitiantimes.com/wp-content/uploads/gravatar/828f7d40dfed95383dad6b43a3a1c307.png' class='avatar 2x photo' width='80'/></a></a></div><div class="abh_social"> <a href="https://www.facebook.com/TheHaitianTimes?ref=settings" title="Facebook" class="abh_facebook" target="_blank" rel="nofollow"></a><a href="https://twitter.com/HaitianTimes_" title="Twitter" class="abh_twitter" target="_blank" rel="nofollow"></a></div><div class="abh_text"><h3 class="fn name" ><a href="https://haitiantimes.com/author/admin/" class="url">Haitian Times</a></h3><div class="abh_job" ></div><div class="description note abh_description" >The Haitian Times was founded in 1999 as a weekly English language newspaper based in Brooklyn, NY.The newspaper is widely regarded as the most authoritative voice for Haitian Diaspora.</div></div> </section><section class="abh_posts_tab abh_tab" ><div class="abh_image"><a href="https://haitiantimes.com/author/admin/" class="url" title="Haitian Times"><img alt='Haitian Times' src='https://haitiantimes.com/wp-content/uploads/gravatar/828f7d40dfed95383dad6b43a3a1c307.png' class='avatar 2x photo' width='80'/></a></a></div><div class="abh_social"> <a href="https://www.facebook.com/TheHaitianTimes?ref=settings" title="Facebook" class="abh_facebook" target="_blank" rel="nofollow"></a><a href="https://twitter.com/HaitianTimes_" title="Twitter" class="abh_twitter" target="_blank" rel="nofollow"></a></div><div class="abh_text"><h4 >Latest posts by Haitian Times <span class="abh_allposts">(<a href="https://haitiantimes.com/author/admin/">see all</a>)</span></h4><div class="abh_description note" ><ul>				<li>					<a href="https://haitiantimes.com/2020/03/12/la-liga-suspended-for-at-least-2-weeks-due-to-coronavirus-outbreak/">La Liga Suspended for At Least 2 Weeks Due to Coronavirus Outbreak</a><span> - Mar. 12, 2020</span>				</li>				<li>					<a href="https://haitiantimes.com/2020/03/12/neymar-is-a-good-actor/">Neymar is a good actor&#8217;</a><span> - Mar. 12, 2020</span>				</li>				<li>					<a href="https://haitiantimes.com/2020/03/12/owen-slams-atleticos-tactics-after-stunning-liverpool-at-anfield/">Owen slams Atletico&#8217;s tactics after stunning Liverpool at Anfield</a><span> - Mar. 12, 2020</span>				</li></ul></div></div> </section></div> </div>		<div class="wpcnt">
			<div class="wpa">
				<span class="wpa-about">Advertisements</span>
				<div class="u belowpost">
							<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-right:5px;margin-top:0px;">
			<div id="atatags-2">
				<script data-cfasync="false" type="text/javascript">
				__ATA.cmd.push(function() {
					__ATA.initSlot('atatags-2',  {
						collapseEmpty: 'before',
						sectionId: '767938381',
						location: 'belowpost',
						width: 300,
						height: 250
					});
				});
				</script>
			</div>
		</div>		<div style="padding-bottom:15px;width:300px;height:250px;float:left;margin-top:0px;">
			<div id="atatags-3">
				<script data-cfasync="false" type="text/javascript">
				__ATA.cmd.push(function() {
					__ATA.initSlot('atatags-3',  {
						collapseEmpty: 'before',
						sectionId: '767938384',
						location: 'belowpost',
						width: 300,
						height: 250
					});
				});
				</script>
			</div>
		</div>
				</div>
			</div>
		</div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div>		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block"
     data-ad-format="autorelaxed"
     data-ad-client="ca-pub-1581876459173802"
     data-ad-slot="5669875954"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>    
		                <div class="clear"></div>
		  </div>
		  <footer class="entry-tools">
		    <span>Mar. 12, 2020</span>		    
		    
		    		    <div class="share"> <a href="https://www.facebook.com/sharer/sharer.php?u=https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" target="_blank" class="facebook"><i class="fa fa-facebook"></i></a>
		        <a href="https://twitter.com/share?text=Haitian+Times+News+Roundup+%E2%80%93+Mar.+12&amp;url=https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" target="_blank" class="twitter"><i class="fa fa-twitter"></i></a>
		        <a href="https://plus.google.com/share?url=https://haitiantimes.com/2020/03/12/haitian-times-news-roundup-mar-12-2/" target="_blank" class="gplus"><i class="fa fa-google-plus"></i></a>
		        <a href="https://pinterest.com/pin/create/button/?media=https://haitiantimes.com/wp-content/uploads/2020/03/SmartSelect_20200311-131613_WhatsApp.jpg&amp;description=Haitian+Times+News+Roundup+%E2%80%93+Mar.+12&amp;url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F" target="_blank" class="pinterest"><i class="fa fa-pinterest"></i></a>
		        <a href="https://www.linkedin.com/shareArticle?mini=true&amp;title=Haitian+Times+News+Roundup+%E2%80%93+Mar.+12&amp;source=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F&amp;url=https%3A%2F%2Fhaitiantimes.com%2F2020%2F03%2F12%2Fhaitian-times-news-roundup-mar-12-2%2F" target="_blank" class="linkedin"><i class="fa fa-linkedin"></i></a>
</div>
		    		  </footer>

		 </div>
		</article> 
	    
				
		<!--Prev / Next-->
		<div class="post_navi">           
		<div class="alignleft item"><i class="fa fa-angle-left"></i><a href="https://haitiantimes.com/2020/03/12/haitian-american-businessmen-convicted-of-port-bribery-scheme-get-new-trial/" rel="prev">Haitian-American businessmen convicted of port bribery scheme get new trial</a></div>		<div class="alignright item"><a href="https://haitiantimes.com/2020/03/12/top-winners-losers-after-wednesdays-champions-league-round-of-16-leg-2-results/" rel="next">Top Winners, Losers After Wednesday&#8217;s Champions League Round-of-16 Leg-2 Results</a><i class="fa fa-angle-right"></i></div> 
		</div>
		
				
		<!--Comment-->
		
<!-- You can start editing here. -->

	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/12/haitian-times-news-roundup-mar-12-2/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://haitiantimes.com/wp-comments-post.php?wpe-comment-post=haitiantimes" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='29113' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="c1a3bba61a" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="82"/></p></form>	</div><!-- #respond -->
	                  
		    </div>
	      </div>
	      
	            
          <!--SideBar-->
	      <aside id="sidebar" class="four columns omega">
	         <div class="widget haiti-widget"><div id="haiti-slider-992" class="custom-slider haiti-slider-411333944 haiti-slider"><ul><li><a data-bid="1" href="https://haitiantimes.com/linkout/26453"><img width="300" height="250" src='https://haitiantimes.com/wp-content/uploads/2019/06/MET2798-Colors-Campaign-Digital-Ads-300x250.gif' alt=''  /></a></li><li><a data-bid="1" href="https://haitiantimes.com/linkout/27151"><img width="300" height="600" src='https://haitiantimes.com/wp-content/uploads/2019/09/300x600_2.jpg' alt=''  /></a></li><li><a data-bid="1" href="https://haitiantimes.com/linkout/29087"><img width="250" height="250" src='https://haitiantimes.com/wp-content/uploads/2020/03/unnamed.png' alt=''  /></a></li></ul></div><script>jQuery(function() {var $haitislider411333944 = jQuery( ".haiti-slider-411333944" );$haitislider411333944.on( "unslider.ready", function() { jQuery( "div.custom-slider ul li" ).css( "display", "block" ); });$haitislider411333944.unslider({ delay:7000, autoplay:true, nav:false, arrows:false });$haitislider411333944.on("mouseover", function(){$haitislider411333944.unslider("stop");}).on("mouseout", function() {$haitislider411333944.unslider("start");});});</script></div><div class="widget haiti-widget"><a data-bid="1" href="https://haitiantimes.com/linkout/19356"><img width="300" height="300" src='https://haitiantimes.com/wp-content/uploads/2018/05/Quality-Journalism-Matter_SOCIAL-blue-e1525475715732.png' alt=''  /></a></div><div id="text-67" class="widget widget_text"><h6 class="widget_title">SIgn In</h6>			<div class="textwidget"><p style="text-align: center;"><a href="https://haitiantimes.memberful.com/auth/sign_in">Sign In</a></p></div>
		</div><div id="ccc_currency_converter_calculator-3" class="widget widget_ccc_currency_converter_calculator"><h6 class="widget_title">Currency Converter</h6><iframe src="https://currencyrate.today/load-converter?lg=en&tz=-5&fm=USD&to=HTG&st=info&bg=FFFFFF&lr=&rd=&wp=ccc" height="289" width="100%" frameborder="0" scrolling="no" class="ccc-iframe" name="ccc-exchange-rates-widget"></iframe><p>Currency Converter: <a href="https://usd.currencyrate.today/htg" target="_blank" class="ccc-base-currency-link">USD/HTG</a></p></div><div id="text-17" class="widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Haitian Times Ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-1581876459173802"
     data-ad-slot="4249011575"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div><div id="text-73" class="widget widget_text">			<div class="textwidget"><!-- /559778808/Article_Rectangle1_300x250 -->
<div id='div-gpt-ad-1478596239649-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1478596239649-0'); });
</script>
</div></div>
		</div><div id="text-74" class="widget widget_text">			<div class="textwidget"><!-- /559778808/Article_Rectangle_300x250 -->
<div id='div-gpt-ad-1478596239649-1' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1478596239649-1'); });
</script>
</div></div>
		</div><div id="text-28" class="widget widget_text">			<div class="textwidget"><a href="https://haitiantimes.com.com/contact-2/"><img class="aligncenter size-large wp-image-10074" src="https://haitiantimes.com.com/wp-content/uploads/2015/02/Place-your-ad-here-footer-1024x127.jpeg" alt="Place your ad here footer" width="560" height="69" /></a></div>
		</div>	      </aside>	      
      </div>      
      <!--Footer-->
            

<footer id="footer">
<div class="footer-main-box">
<a href="/" class="footer-logo"><img src="https://haitiantimes.com/wp-content/themes/citynews/images/Haitian-times-small-logo.png" alt="Haitian Times" /></a>

<ul class="footer-sections">
<button class="collapsible">NEWS</button>

<div class="contentftr">
<li><a href="https://haitiantimes.com/category/latest-news/">Latest News</a></li>
<li><a href="https://haitiantimes.com/category/immigration-migration/">Immigration & Migration</a></li>
<li><a href="https://haitiantimes.com/category/protests/">Protests</a></li>
<li><a href="https://haitiantimes.com/category/travel/">Travel</a></li>
<li><a href="https://haitiantimes.com/category/business/">Business</a></li>
<li><a href="https://haitiantimes.com/category/elections/">Elections</a></li>
<li><a href="https://haitiantimes.com/category/politics/">Politics</a></li>
<li><a href="https://haitiantimes.com/category/tech/">Tech</a></li>
<li><a href="https://haitiantimes.com/category/caribbean/">Caribbean</a></li>
</div>
</ul>

<ul class="footer-sections">
<button class="collapsible">DIASPORA</button>

<div class="contentftr">
<li><a href="https://haitiantimes.com/category/new-york/">New York</a></li>
<li><a href="https://haitiantimes.com/category/boston/">Boston</a></li>
<li><a href="https://haitiantimes.com/category/south-florida/">South Florida</a></li>
<li><a href="https://haitiantimes.com/category/montreal/">Montreal</a></li>
<li><a href="https://haitiantimes.com/category/france/">France</a></li>
<li><a href="https://haitiantimes.com/category/the-americas/">The Americas</a></li>
</div>
</ul>

<ul class="footer-sections">

<button class="collapsible">OPINION</button>

<div class="contentftr">
<li><a href="https://haitiantimes.com/category/editorial/">Editorials</a></li>
<li><a href="https://haitiantimes.com/category/warped-lens/">Warped Lens</a></li>
<li><a href="https://haitiantimes.com/category/op-eds/">Op-eds</a></li>
<li><a href="https://haitiantimes.com/category/columns/">Columns</a></li>
</div>
</ul>

<ul class="footer-sections">

<button class="collapsible">FEATURES</button>

<div class="contentftr">
<li><a href="https://haitiantimes.com/category/haiti-talks/">Haiti Talks</a></li>
<li><a href="https://haitiantimes.com/category/haitians-in-america/">Haitians in America</a></li>
<li><a href="https://haitiantimes.com/category/immigrant-voices/">Immigrant Voices</a></li>
<li><a href="https://haitiantimes.com/category/lists/">Lists & Guides</a></li>
<li><a href="https://haitiantimes.com/category/profiles/">Profiles</a></li>
</div>
</ul>

<ul class="footer-sections">

<button class="collapsible">MORE</button>

<div class="contentftr">
<li><a href="https://haitiantimes.com/category/classifieds/">Classifieds</a></li>
<li><a href="https://haitiantimes.com/category/video/">Video</a></li>
<li><a href="https://haitiantimes.com/category/photo-gallery/">Photo Galleries</a></li>
<li><a href="https://haitiantimes.com/category/entertainment/">Entertainment</a></li>
<li><a href="https://haitiantimes.com/category/style/">Beauty & Style</a></li>
<li><a href="https://haitiantimes.com/category/sports/">Sports</a></li>
</div>
</ul>

<ul class="footer-sections">

<button class="collapsible">ABOUT</button>

<div class="contentftr">
<li><a href="https://haitiantimes.com/about-the-haitian-times/">About Haitian Times</a></li>
<li><a href="https://haitiantimes.com/category/company-updates/">Company Updates</a></li>
<li><a href="https://haitiantimes.com/republishing-guidelines/">Republishing Guidelines</a></li>
<li><a href="https://haitiantimes.com/careers/">Careers</a></li>
<li><a href="https://haitiantimes.com/contact-2/">Contact</a></li>
</div>
</ul>

<script>
var coll = document.getElementsByClassName("collapsible");
var i;

for (i = 0; i < coll.length; i++) {
  coll[i].addEventListener("click", function() {
    this.classList.toggle("active");
    var contentftr = this.nextElementSibling;
    if (contentftr.style.maxHeight){
      contentftr.style.maxHeight = null;
    } else {
      contentftr.style.maxHeight = contentftr.scrollHeight + "px";
    } 
  });
}
</script>


</div>


        
        <div class="container">
	     <div class="copyright eight columns">
		      		        <div class="copyright-box">Copyright &copy; 2019 <a href="https://haitiantimes.com/" title="The Haitian Times">The Haitian Times</a>. All rights reserved.</div> <div class="website-BM-canada"><span><a href="http://baileymedia.ca/website-project-request/" target="_blank">Website services & maintained</a> by</span> <a href="http://baileymedia.ca/" target="_blank"><h1 style="font-size:10px; color:#FFFFFF;">Bailey Media Canada</h1></a></div>
		      
	     </div>
	             </div>
      </footer>



      
              
      <!--Popup-->
      <div id="popup_window" class="popup_content">
        <a href="javascript:void(0)" class="close_popup"><i class="fa fa-close"></i></a>
	    
	    	    <div id="popup_search" class="popup_content">
		    <h3>Searching</h3>
		    <div class="content container">
			  <form action="https://haitiantimes.com/" method="get" name="searchform" class="popup_form">
			      <div class="eight columns alpha">
				    <input type="text" name="s" class="u-full-width" placeholder="Keyword" />
			      </div>
			      <div class="four columns alpha omega">
				  	<input type="submit" name="search_button" class="button-primary" value="Search" />
			      </div>
			  </form>
		    </div>
	     </div>
	     	    
	     
	     	     
      </div>
      <div class="page_mask"></div>        
      </div><!--//body container-->
      
      
      
            <!-- ngg_resource_manager_marker --><script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/haitiantimes.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202011'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"haiti-layer"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.6.5'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.sticky.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.easing.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.masonry.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.superfish.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.nicescroll.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.justifiedGallery.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/pushy.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/js_composer/assets/lib/bower/flexslider/jquery.flexslider-min.js?ver=4.12.1'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.flexloader.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.validate.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/send-mail.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.simpleWeather.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/imagesloaded.min.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/swiper.jquery.min.js'></script>
<script type='text/javascript' src="https://www.geoplugin.net/javascript.gp"></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/jquery.hoverdelay.js'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/assets/js/citynews.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxcomment = {"ajax_url":"https:\/\/haitiantimes.com\/wp-admin\/admin-ajax.php","order":"asc","formpostion":"bottom"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews-child/assets/js/ajax-comment.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/official-mailerlite-sign-up-forms/assets/js/jquery.validate.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://haitiantimes.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://haitiantimes.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://haitiantimes.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 0;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSssWhatsappShareAPI = "web";
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var advadsTracking = {"ajaxurl":"https:\/\/haitiantimes.com\/wp-admin\/admin-ajax.php","ajaxActionName":"aatrack-records","method":null,"blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/script.js?ver=1.19'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script async="async" type='text/javascript' src='https://haitiantimes.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<script type='text/javascript' src='https://haitiantimes.com/wp-content/themes/citynews/inc/shortcodes/js/shortcodes.js'></script>
<script>
		var advanced_ads_ga_UID = false;
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();</script><!-- Your Google Analytics Plugin is missing the tracking ID -->
<script type="text/javascript">
   var comment_title="COMMENT ON THIS POST";
   var temperature_unit="f";
   </script><script>window.advads_has_ads = [["26451","ad",null],["27153","ad",null],["26481","ad",null],["25353","ad",null],["26453","ad",null],["27151","ad",null],["29087","ad",null],["19356","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( window.advanced_ads_pro ) {advanced_ads_pro.process_passive_cb();} else if ( window.console && window.console.log ) {console.log('Advanced Ads Pro: cache-busting can not be initialized');} });</script><script type='text/javascript' src='https://stats.wp.com/e-202011.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'76793838',post:'29113',tz:'-4',srv:'haitiantimes.com'} ]);
	_stq.push([ 'clickTrackerInit', '76793838', '29113' ]);
</script>
<script>
ai_insert=function(a,e,h){var f=-1!=e.indexOf(":eq")?jQuery(e):document.querySelectorAll(e);Array.prototype.forEach.call(f,function(b,f){selector_string=b.hasAttribute("id")?"#"+b.getAttribute("id"):b.hasAttribute("class")?"."+b.getAttribute("class").replace(RegExp(" ","g"),"."):"";var d=document.createElement("div");d.innerHTML=h;var c=d.getElementsByClassName("ai-selector-counter")[0];null!=c&&(c.innerText=f+1);c=d.getElementsByClassName("ai-debug-name ai-main")[0];if(null!=c){var g="";"before"==
a?g=ai_front.insertion_before:"after"==a?g=ai_front.insertion_after:"prepend"==a?g=ai_front.insertion_prepend:"append"==a?g=ai_front.insertion_append:"replace-content"==a?g=ai_front.insertion_replace_content:"replace-element"==a&&(g=ai_front.insertion_replace_element);-1==selector_string.indexOf(".ai-viewports")&&(c.innerText=g+" "+e+" ("+b.tagName.toLowerCase()+selector_string+")")}c=document.createRange().createContextualFragment(d.innerHTML);"before"==a?b.parentNode.insertBefore(c,b):"after"==
a?b.parentNode.insertBefore(c,b.nextSibling):"prepend"==a?b.insertBefore(c,b.firstChild):"append"==a?b.insertBefore(c,null):"replace-content"==a?b.innerHTML=d.innerHTML:"replace-element"==a&&(b.parentNode.insertBefore(c,b),b.parentNode.removeChild(b))})};
ai_insert_code=function(a){function e(a,b){return null==a?!1:a.classList?a.classList.contains(b):-1<(" "+a.className+" ").indexOf(" "+b+" ")}function h(a,b){null!=a&&(a.classList?a.classList.add(b):a.className+=" "+b)}function f(a,b){null!=a&&(a.classList?a.classList.remove(b):a.className=a.className.replace(new RegExp("(^|\\b)"+b.split(" ").join("|")+"(\\b|$)","gi")," "))}if("undefined"!=typeof a){var b=e(a,"no-visibility-check")?!0:!!(a.offsetWidth||a.offsetHeight||a.getClientRects().length);a.getAttribute("data-block");
if(b){b=a.getAttribute("data-code");var k=a.getAttribute("data-insertion"),d=a.getAttribute("data-selector");null!=b&&(null!=k&&null!=d?document.querySelectorAll(d).length&&(ai_insert(k,d,b64d(b)),f(a,"ai-viewports")):(b=document.createRange().createContextualFragment(b64d(b)),a.parentNode.insertBefore(b,a.nextSibling),f(a,"ai-viewports")));a=a.getElementsByClassName("ai-check-block");"undefined"!=typeof a[0]&&a[0].parentNode.removeChild(a[0])}else b=a.previousElementSibling,e(b,"ai-debug-bar")&&
e(b,"ai-debug-script")&&(f(b,"ai-debug-script"),h(b,"ai-debug-viewport-invisible")),f(a,"ai-viewports")}};function b64e(a){return btoa(encodeURIComponent(a).replace(/%([0-9A-F]{2})/g,function(a,h){return String.fromCharCode("0x"+h)}))}function b64d(a){return decodeURIComponent(atob(a).split("").map(function(a){return"%"+("00"+a.charCodeAt(0).toString(16)).slice(-2)}).join(""))};

</script>
<script type="text/javascript">var advads_tracking_ads = {};var advads_tracking_urls = [];var advads_gatracking_uids = [];var advads_tracking_methods = [];var advads_tracking_parallel = [];var advads_tracking_linkbases = [];var advads_gatracking_allads = [];var advads_gatracking_anonym = true;</script>

    </body>
</html>